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Can't wait to hear from the
head of Google India sales!]
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Tutorial Recap
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Activity 2

q | DisplayMessageActivity

Can't wait to hear
from the head of
Google India
sales!!
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Tutorial Recap: Activities

Activity 1 Activity 2
AN 2:15

S FirstAppindia QO DisplayMessageActivity

ool of Googte tndia salngyl I Can't walit to hear
| | from the head of
Google India
salesl!!

Activity 1.xml

Activity 1.java
Activity 2.xml

Activity 2.java




Tutorial Recap: Buttons

Activity 1

S FirstAppindia

Can't wait to hear from the

head of Google India sales!|

Send

Button

Activity 1.xml:

 add button, give
“directions” on what to
do with a click event
(name of a click event
method that
determines behavior)

Activity 1.java:
 Contains our behavior

function that came from
the xml file



Tutorial Recap: Intent

Activity 1 Activity 2
AN 2:15

S FirstAppindia QO DisplayMessageActivity

Can't wait to hear from the Send Butt ' I
“head of Google India sales!! | ' C|is|< I(E)\?ent Can t Walt to hear
Text field from the head of
Google India
Intent
_sales!!
(Contains
message
object)
Click Event Method (in Activity 1.java) onCreate Method (in Activity 2.java)
» Create the Intent Object « get the intent object
« Add the message to it « get the message from the intent
 Start the activity in the intent object
object (activity 2) )




Overview

® Models of app navigation

O The activity stack
O ListView/GridView

© Menus

O Dialogs and Notifications

® Using navigation in your app

Wednesday, July 4, 12



The Activity Stack

‘, Start Activity 2 l ( Start Activity 3 l | Navigate back j

Activity 1 Activity 2 Activity 3 Activity 2
Activity 1 Activity 2 I Activity 1
oyt |
time —

The activity stack is usually used to separate modal actions
(i.e. different modes: “reading mail” = “writing reply”)
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How to use
the Activity Stack

GridView Gallery
— > » ] Lists/Overview
CLJ
ListView Categories (if needed)

\ 4 l v
- e
, | Detail Views

Generally: Navigate from lists/overview to details!
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How to use
the Activity Stack

Inbox ’ Mumbai AITI Expense Sharing Reol >
comradecosmobot@gmail.co... 4 ; (comradecosmobot@gmail.com) ‘ eply
B ake (Google .. Jul 3 Mumbai AITI Expense Sharing :
- T et Sghanng Gonslaistiichoianall oo comradecosmobot@gmail.com
(c smobot@gmail.com) e (G..
-
2 H Bryan Drake (Google Docs)
Bryan Drake 2 P beyangdrake@om..
Fwd: You Have to do this X .
) To: comradecosmobot@gmai ul 3 ) Re: Mumbai AITI Expense
Sharing
bryangdrake@gmail.c.. Jul l Always show pictures from this (comradecosmobot@gmail.
bryangdrake@gmail.com has shared a B sender cdm) P pn e e s
calendar with you
S~ «= I've shared Mumbai AITI
Bryan Drake Jun 78 " Expense Sharing
Fwd: Short Bios
h Click to open
Mumbai AIT] Expense Sharing QWEWRTYU I OFP
Bryan Drake
Fwd: PR for MIT AITI Program — Hey lar
Can you get in touch with Abhishek A s D F G H J K L
Bryan Drake Google docs 44 Z XCVBNM®ER
Tuming off flash messaging on
Vodafone smartfones — It's under an
. -
A Q = & dayy > : V=

List Detail (View) Detail (Reply)

Also useful for temporary states (e.g. replying to e-mail)
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Using the Activity Stack

¥ ¥
Navigation Examples Navigation Examples

Hello world! Hello world, this is another activity!

Start Another Activity

Lal

NavigationExamples AnotherActivity
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The Code:
onClickMe()

public class NavigationExamples extends Activity {
public void onClickMe(View button) {
/* Create an Intent to start AnotherActivity */
Intent startAnotherActivity =
new Intent(NavigationExamples. this,
AnotherActivity.class);

/* Start the activity. */
startActivity(startAnotherActivity);
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Using the Activity Stack:
Demo




Aside: The Manifest
and Intent Filters

Application Nodes @ @ @ e @ @ @ Az

» (9 .NavigationExamples (Activity)

¥ (9 .AnotherActivity , _
lentent Filter Remove...

@android.intent.action.MAIN (Action) : '

© android.intent.category.LAUNCHER (Category)

Add...

Up

Down

=] Manifest Application @ Permissions [D Instrumentation | =| AndroidManif
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Aside: The
and Intent

Application Nodes

BP®CR®O Az

P @ .NavigationExamples (Activity)

Add...
¥ (9 .AnotherActivity
?E]Intent Filter Remove...
@android.intent.action.MAIN (Action) 3
p

© android.intent.category.LAUNCHER (Category)

=] Manifest Application [E] Permissions [D Instrumentation | = AndroidManif

This will appear as a separate launcher! —

anifest
ilters

%mg 11:51 am

@ 3 =

pe

Calculator

&

Custom
Locale

Alarm Clock Another Browser

Activity

]
S
et
g

Camera Car Home Contacts

# B

Dev Tools Email Gallery

Q @

Phone

(1)
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Aside: The Manifest
and Intent Filters

Application Nodes @ @ @ G @ @ @ Az Attributes for android.intent.category. ALTERNATIVE (Category)

© Attributes that can be supplied in an AndroidManifest.xml category tag,

» (9 .NavigationExamples (Activity) Add... a child of the intent-filter tag.

¥ (9 .AnotherActivity

v E] Intent Filter Remove...
@android.intent.action.MAIN (Action)

© android.intent.category. ALTERNATIVE (Category)

Name | android.intent.category.ALTERNATIVE

Up

android.intent.category. ALTERNATIVE makes it an
“alternative” activity (which won’t appear in the menu)
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ListView and GridView




ListView and GridView

——
B S
T s ey
_S—— EEEE
EEEEE e
p— R
ListView GridView

Useful to organize lists of items for further detail
(e.g. lists of nearby restaurants, lists of train times...)




Adapters

Content Provider ListView, GridView,
—| Adapter —
or Array... etc...

Data Flow —

Adapters “wrap” a data source (database, array, etc.)
for use in aView (ListView, GridView, Spinner, etc.)
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Using a ListView

Navigation Examples

tem 1

Sub ltem 1

tem 2

Sub Item 2

tem 3
Sub Item 3

tem 4

Sub Item 4

Iltem 5

Sub Item 5

Item 6
Sub ltem 6

Iltem 7

Sub Item 7

NavigationExamples
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The Code:
onCreate()

public class NavigationExamples extends Activity {
public void onCreate(Bundle savedInstanceState) {
/* Initialize the Activity =*/
super.onCreate(savedInstanceState);
setContentView(R.layout.activity_navigation_examples);

/* Set up the ListView's adapter =*/
ListView myListView =
(ListView) findViewById(R.id.myListView);
ArrayAdapter<String> statelList =
new ArrayAdapter<String>(this,
android.R.layout.simple_list_item_1,
getResources().getStringArray(R.array.states));
myListView.setAdapter(statelList);

/* ... %/
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The Code:
onCreate()

[* ... %/

/* Listen for clicks on each item in the ListView */
myListView.setOnItemClicklListener(
new OnItemClickListener() {
public void onItemClick(AdapterView<?> parent,
View view, int position, long id) {
/* Start AnotherActivity... */
Intent anotherActivityIntent =
new Intent(NavigationExamples.this,
AnotherActivity.class);
startActivity(anotherActivityIntent);

}
1)
}

Wednesday, July 4, 12



Using a ListView:
Demo




Menus
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Menus

(]

v S <

Bl hutp://www.google.com/... |
Web Images Places News more + @ Henry IV (1)
Henry V
Google
Henry VIl
Q
[ t (beta)
Richard 11l
P <o Se Merchant of Venice
Othello
King Lear

Windows

Option Menu
Floating context menu and contextual action bar

Useful for common modes or actions related to an Activity
(Context menus are useful for items IN aView)
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Option Menus

All Activities have an option menu!

public class NavigationExamples extends Activity {
@Override
public boolean onCreateOptionsMenu(Menu menu) {
getMenuInflater().inflate(
R.menu.activity_navigation_examples, menu);
return true;
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Option Menus

s N 7 Vi s -
[ Package Explorer 53 N = 0O || lJ] LablActivity.java ltg activity_labl.xml AZ 5621430 [labl] M’S = =
& | ) == g
. o ‘W Android Menu
» =i Android 4.1 Menu Elements 0 Q) Az Attributes for menu_settings (Item)
» =, Android Dependencies )
€l — Base attributes that are available to all Item
k g?-zssets (B menu_settings (Item) Add objects.
=% bin
€l 1 Id +id/menu_setting | Browse...
> gﬁ'"bs Remove... adl = .
Viyres Menu category v
> (5 drawable-hdpi Up
P (% drawable-ldpi — Order in category 100
Y W
» (5 drawable-mdpi Title @string/menu_setti | Browse...
> (53 drawable-xhdpi
> iy layout Title condensed Browse...
v m\enu Icon
\C}y activity_another.xml
E&activity_navigation_example Alphabetic shortcut Browse...
P (& values
> gvalues—large Numeric shortcut Browse...
> gvalues-vll Checkable [ lv|
> Sy values-v14 . .
1, AndroidManifest.xml Checked X
@ ic launcher-web.ona Visible [ Tv ]
7 " ~ | |
'@ Git Repositories 83 = Im Ees )
<§> | Bﬁ :ﬁ Ef éb <§> I T @ =2 On click Browse...
project.properties Show as action never Select...
> .settings =
> g B g Layout | ‘= activity_navigation_examples.xml
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The Code:
onOptionsItemSelected()

public class NavigationExamples extends Activity {
public boolean onOptionsItemSelected(Menultem item) {
/* Choose your action based on the item selected. */
switch (item.getItemId()) {
case R.id.menu_settings:
/* Make the settings appear. */
return true;
default:
return super.onOptionsItemSelected(item);
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Context Menus

® Very similar to Option Menus

e onCreateContextMenu() instead of
onCreateOptionsMenu()

O Include super.onCreateContextMenu() first

¢ onContextItemSelected() instead of
onOptionsItemSelected()

® ((AdapterContextMenulInfo)
menultem.getMenulnfo()).1d

gets the item context in onOptionsItemSelected
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Using Menus:
Demo




| Taught You That So | Could
Teach You This:
The Action Bar




The Action Bar

At the top of the screen, this is better than a menu

BALLOONS BIKES ANDROIDS PASTRIES [Sj_]

Wednesday, July 4, 12



The Action Bar

At the top of the screen, this is better than a menu

BALLOONS  BIKES  ANDROIDS  PASTRIES o)

Downside: It’s only supported on Android 3.0+ (APl Level | | +)




The Action Bar

At the top of the screen, this is better than a menu

BALLOONS BIKES ANDROIDS PASTRIES [(': E‘j

Downside: It’s only supported on Android 3.0+ (APl Level | | +)

But there is some sample compatibility code in
<sdk>/samples/<android-version>/ActionBarCompat/
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The Action Bar

Just like Option Menus!

® Uses onCreateOptionsMenu() and
onOptionsItemSelected()

® Make Action Bar ltems using menu
resources




Activating the Action Bar

f (8 Package Explorer % = |ml| 'g activity_navigation_ \;Q styles.xml ] project.properties =" [m||
[ B | = 2 g
83 W' Android Manifest
> (s drawable-Idpi - -
» G drawable-mdpi v Manifest General Attributes
> @ drawable-xhdpi Defines general information about the AndroidManifest.xml
¥ (=% layout Package edu.mit.aiti.india.navexamples Browse...
1< act!thy_ano.ther..xml PR "
(C} activity_navigation_example
¥ [y menu Version name 1.0 Browse...
(T}, activity_another.xml|
352 Lo Shared user id Browse...
(C}y activity_navigation_example
¥ (5 > values Shared user label Browse...
(C}, dimens.xml
) strings.xm Install location v |
(> styles.xml - -
b (G values-large Manifest Extras @ @ ® @ @ ® @ Az Attributes for Uses Sdk
P (S values-vll —— (U) The uses-sdk tag describes the SDK features
b (4 values-v14 (D) Uses Sdk Add... that the containing package must be running on
7y AndroidManifest.xml = tpioperate correctly,
& ic_launcher-web.png sl Min SDK version = Browse...
— proguard-project.txt
I;a 3 g S ; Up Target SDK version | 15 Browse...
5 project.properties
Down Max SDK version
(9 Git Repositories 33 = {m| M M S D K T S DK > I I
ER|RBE e 8T In or arget

» [] ILikeMumbai [master] - /Users/ianjacot|] v Exporting

» (] labl [56f21d30823cb6c9b68f4449602:|| - ---~.;-~ @ '|_' - [E] N [I] 2 al T i€ :
» [ navexamples [master] - /Users/ianjacol Manifest Application Permissions Instrumentation | =| AndroidManifest.xm
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Activating the Action Bar

N 7

> (5 drawable-xhdpi
¥ (= layout
(C}, activity_another.xml
O}y activity_navigation_e
¥ (&% > menu
7}, activity_another.xml|
<} > activity_navigation_e:
¥ (S values
(C}; dimens.xml
(C}, strings.xml|
T}y styles.xml
P (s values-large
> (S values-vll
> (S values-v14

@ Git Repositories 23

ERAEEEISIERAL
» [] ILikeMumbai [master] - /Users/

» [J labl [56f21d30823cb6cOb6Bf44H
» [] navexamples [master] - /Users fial

f 5 Package Explorer 23 = |m| <1 activity_navigation_
R || == 3
=R l W Android Menu
¥ Z3bin
> Gv_l-ErlibS Menu Elements
v Eﬁ > res
» (% drawable-hdpi (1) menu_settings (item)
P (s drawable-Idpi -
> (=7 drawable-mdpi l - HeNS)

| Q) activity_another.xml £3 \_|d styles.xml

' <1 Navigation Examples

))1 1

@ A=

Add...

Select the flag values for attribute Show as action:

| | never
|| always
|| withText

|| collapseActionView

Attributes for menu_settings (Item)

(1 ] Base attributes that are available to all item

objects.

Id @+id/menu_setting | Browse...
Menu category lw |
Order in category 100

Title @string/menu_setti | Browse...
Title condensed Browse...
Icon

Alphabetic shortcut Browse...
Numeric shortcut Browse...
Checkable |w |
Checked r v |
Visible v |
Enabled lv |
On click Browse...

never

|Show as action

’ Select... Il
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The Action Bar:
Demo




Dialogs and Notifications




Dialogs and Notifications

25 April 2009 Dl @ 3:41pm

800 - . Android _ Clear notifications .
R.Qn am ey e e —

This alarm Is set for 17 hours and 57 [T Travis

minutes from now. where v
9:.00 o

AlertDialog
Toast Notification Status Notification

AlertDialogs ask for simple user input.
Other dialogs are used to show progress of an action.

Notifications let the user know of a background event
(e.g.“2 new e-mails!” or “An update has been downloaded”)
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Alert Dialogs: Code

AlertDialog.Builder builder = new AlertDialog.Builder(this);
builder.setMessage("You clicked the context menu!")
.setCancelable(false)
.setPositiveButton("Yes",
new DialogInterface.OnClickListener() {
public void onClick(DialogInterface dialog, int id) {
dialog.cancel();

)
.setNegativeButton("No",

new DialogInterface.OnClickListener() {
public void onClick(DialogInterface dialog, int id) {
dialog.cancel();

D
AlertDialog dialog = builder.create();

dialog.show();
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Toast Notifications: Code

Toast.makeText(this,
"This 1s a toast notification!",
Toast.LENGTH_SHORT)
.show() ;
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Status Notifications: Code

/* Get the NotificationManager service. */

String ns = Context.NOTIFICATION_SERVICE;

NotificationManager mNotificationManager =
(NotificationManager) getSystemService(ns);

/* Create the notification. */

int icon = R.drawable.ic_launcher; // Icon
CharSequence tickerText = "The ticker text"; // Ticker Text
long when = System.currentTimeMillis(); // When to show

Notification notification = new Notification(
icon, tickerText, when);
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Status Notifications: Code
(Continued)

Context context = getApplicationContext();

CharSequence contentTitle = "My notification”;

CharSequence contentText = "Hello World!";

/* This intent to restart is "delayed" for a later date. */

Intent notificationIntent = new Intent(
this, NavigationExamples.class);

PendingIntent contentIntent = Pendinglntent.getActivity(
this, 0, notificationIntent, 0);

notification.setlLatestEventInfol(
context, contentTitle, contentText, contentIntent);

final int HELLO_ID = 1;
mNotificationManager.notify(HELLO_ID, notification);
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Resources

®  Android Developer Site

O

O

O

O

O

“ListViews” <http://developer.android.com/guide/topics/ui/layout/listview.htmI>

“Menus” <http://developer.android.com/guide/topics/ui/menus.htm|>

“Action Bar” <http://developer.android.com/guide/topics/ui/actionbar.htm|>

“Dialogs” <http://developer.android.com/guide/topics/ui/dialogs.html>

“Notifications” <http://developer.android.com/guide/topics/ui/notifiers/index.html>

®  Android Design (on the Developer Site)

O

O

“App Structure” <http://developer.android.com/design/patterns/app-structure.html>

“Navigation” <http://developer.android.com/design/patterns/navigation.htm|>
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More Resources

®  Android Training (on the Developer Site)

O “Designing Effective Navigation”
<http://developer.android.com/training/design-navigation/index.html>

O “Implementing Effective Navigation”
<http://developer.android.com/training/implementing-navigation/index.html>

®  Android Patterns (a list of useful interaction patterns for Android apps)
<http://www.androidpatterns.com/>

®  Giorgio Venturi has a presentation about Android Design Patterns
<http://www.closertag.com/thought-pieces/android-design-patterns/>
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Version Control




What is version control?

Version control is a way to manage
the history of a project’s source code.




Types of version control

® Client/Server (CVS, SVN, SourceSafe...)

® Distributed (Git, Mercurial, bazaar...)

We will use Git in the labs.




Version Control Concepts

® Revision/Commit — Saved version of source
® Jo commit (verb) — To save the version

® Repository —VVhere the history is stored




Install EGit (Version Control

Adding a new software site

There are several different ways to add a software site to the list of sites that are used when browsing available software and checking for updates. You must
know the Web Site location (URL) of the site that you want to add. To add the site, use one of the following procedures:

e Add a new site using the ¥= Install/Update > Available Software Sites preference page.

1.
2.
3.

Click the Add... button.
Type a name into the Name text box.

If the software site is located on the web, type the Web Site location (URL) of the site into the Location text box. You may also paste or drag and
drop a URL from a web browser into this text box.

If the software site is in your local file system (including a CD), click Local... to specify the directory location of the site.
If the software site is in your local file system but is packaged as a jar or zip file, click Archive... to specify the name of the file.

http://download.eclipse.org/egit/updates

SMIT ATH v



Setting up Egit

Add your information:

e Select Preferences->Team-> Git ->
Configuration

» Add your name and email in two separate
new entries

» Use user.email and user.name in the “key”

field

eMIT AT’



Setting up Egit

e OO0 Preferences
type filter text Configuration P
P General
P Android — System Settings Repository Settings }4
P Ant
:2‘/’2‘3 seadio Location: | /Users/JonGibbs/.gitconfig ' [ open |
P Help |
> Install/Update Key. Value | Add Entry... |
b Java Vcolor —
» PyDev ul R |  Remove |
> Run/Debug Vcore ) ‘
¥Team autocrlf false
File Content Vuser . o .
Git email jaygibbs@gmail.com
YGit name Jon Gibbs
Commit Dialog
Confirmations and Wz
History
Label Decorations
Projects
Synchronize
Window Cache
Ignored Resources
Models
Validation
XML
| Restore Defaults | Apply
@ |  Ccancel | [ OK

EMIT AT "
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It using windows:

Setting up the Home Directory on Windows

Add the environment variable soMe to your environment variables.

In Windows 7, type "environment" at the start menu

Select "Edit environment variables for your account”

Click the "New" button.

Enter "HOME" in the name field

Enter "%USERPROFILE%" or some other path in the value field.

Click OK, and OK again. You have just added the Home directory on Windows.

2B o o e

MIT AT "
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Using EGit

e 00 Java - FirstApplndia/res/values/strings.xml - ADT - /Us¢
i QU aBUddN 0% H#EG & v &l
[% Package Explorer $3 = B8 || A activity_dis... [J) DisplayMessa... al st
o Bg ¥ <?xml version="1.0" encoding="utf-8"
reate a repositor
~ |
y v (@ src :e“ll name="app_name ">FirstApp!
'H&gom»e: o Into name="action_settings">S«
» [J] Mai C d name="hello_world">Hello
° ° . > &“gen [Geng¢ ommands >
> =) i . B r
¢ Ri t Click on the Project e
. .
J s, assets Open Type Hierarchy ) Fa4
» &2 bin Show In X #W >

> &= libs 5 Publish >

Select Team -> Share .

£2 Copy Qualified Name

F :{Ejmw“:  Paste sV
I (= drawal
ro e Ct » (= drawal ¥ Delete ®
=y .
J ;S RvOu Build Path N
C u )
¥ (= values Source X #S >
4 dim  Refactor N&T >
Q) stril
q syl 2almport...
b (values 4 Export...
» (= values: %
b (Svalues & Refresh -

» =values  Close Project
a AndroidM  Close Unrelated Projects
Fic_launch  Assign Working Sets...

|=|proguard:
[E projectpr  Run As >
> 5 > MyFirstAp|  Debug As >
Profile As >
Validate
Apply Patch...

Compare With > .
Restore from Local History... Share Project...
PyDev >
Android Tools >
Properties 81
Resource Configurations >

T

36
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Create

Select “"Git” on the next
screen, click next

Create a new directory
OUTSIDE of your working
directory

Click through to “Finish”

d

repository

Configure Git Repository

Configure Git Repository
Select an existing repository or create a new one LU
|_| Use or create repository in parent folder of project
Repository: +| | Create...
Working directory: No repository selected
Path within repository: Browse
Project Current Location Target Location
v = FirstAppindia /Users/JonGibbs/Jon's Work/AITI/Andriod...
[NeNs) Create a Git Repository
Create a New Git Repository
Please determine the directory for the new repository
Parent directory: | /Users/JonGibbs/git | Browse...
. Name: |
7 [ -
'\?/’ B Finist
M ™ P T
77\
@ | Cancel Finish —
[=] Resources | (5] st —

& MIT AT
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Create a repository

You should see an error v
N yOUI’ app (Don t ¥ £ com.example.firstappindia
WO rry) > 4l MainActivity.java

> E—ﬁgen [Generated Java Files])
» =, Android 4.2.2
&3 assets

Select Team->Add to b gy bin
Index > Eglibs
v (res
> (gfydrawable-hdpi
. . . (-3 drawable-ldpi
Right click the bin folder > G, dravable-mdp
and select Team- > Gycrawable-xhdp
gy drawable-xxhdpi
>|gnore > (g layout
> (gymenu
V (s values

e dimens.xml

MIT AT "
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Add the .gitignore file

. Java - FirstAppind ralues 3s.xml - ADT - /U Wo
elect the down e @ BEE GNP O UEG P S  Br
[£ Package Explorer 3 = B || a activity_dis... [J] pisplayMessa... q strings.xml a| MyFirstApy

> (fsrc
b‘aﬁgen Gene

P =, Android 4.2.2

Z3-assets
- [S E—“bin </Pl{ The patterns are separated by comma, where

> &:Iibs * = any string, ? = any character, ,, =,

° =2<& v <?xml version="1.0" encoding="utf-8"7?>
a rrOW I I l p a C a g e ¥ &3> FirstAppindia [FirstindiaApp NO-HEA a8 JavalElementiEilters

erated Java Files Name filter patterns (matching names will be hidden):

> E“res
. ) )
g AndroidManifest.xml Select the elements to exclude from the view:
% ic_launcher-web.pn
I e I S Hiclau web.png .* resources
|5gl proguard-project.txt Closed projects

|5} project.properties @ Empty library containers
> MyFirstApp [MyFirstApp Empty packages

@ Empty parent packages
. l | Fields
n C e C e ™ Import declarations
™ Inner class files

Java files
Libraries from external

resources box

» Add the .gitignore
file to the index

Cancel OK |

g MIT AW v



Commit the changes to your

 Right click your
project and
select Team ->
Commit

reposit

ory

MIT AT’

8 0 O Java - FirstApplndia/res/values/strings.xml - ADT - /Users/Jon!
i Q- aBd-dNB-0- QU HEG & v §lv 4o Gy
[% Package Explorer &3 = 8 | a activity_dis... [J] pisplayMessa... <l strings.xml
9% v <?xml version="1.0" encoding="utf-8"25
& = = - = <resources>
> %ﬁsrc New > tring name="app_name">FirstAppIndia</
> figer  Go Into tring name="action_settings">Settings
P =) Anc tring name="hello_world">Hello world!
T3ass Commands >
» o bi ) N arces>
>§n$ Open in New Window
> Eﬁre; Open Type Hierarchy F4
ol -cla Show In N 8W >
&gt 8 Publish >
Wy .pri
G Anc = Copy #C
#ic| E2 Copy Qualified Name
GdPre = paste E3Y
= Pro
PE%-I:#b:yF ¥ Delete ©
Build Path > . -
Source T 8S S ~§ Commit... %83
Refactor NRT IS Fetch from Upstream
Push to Upstream
3 Import...
4 Export... Pull
> Ref %1 Synchronize Workspace
<" Re resh Merge Tool
Close Project = Merge
Close Unrelated Projects N R ge...
Assign Working Sets... eset...
Create Patch...
Run As > Apply Patch...
Debug As > 4+ Add to Index
Proﬁle As > % Remove from Index
Validate #) Ignore
Team . il 65 Untrack
Compare With . N )
. [ Show in Repositories View
Restore from Local History... | Show in Hi
PyDev > 5] ow in History
Android Tools > Remote >
Properties 32| 2 Switch To >
Resource Configurations »  Advanced >
m Rebase...
[=] Resources
- - &7 Disconnect
FirstAppindia
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Commit the changes to your
repository

« Add a message
and commit the
files!!

e Quit and Restart
Eclipse ADK

10 0 O Commit Changes
Commit Changes to Git Repository
Gull
Commit message SEY
- .

YFirst Commit

Author: Jon Gibbs <jaygibbs@gmail.com>

Committer: | Jon Gibbs <jaygibbs@gmail.com>

Files (34/34) 2|| [¥]

type filter text

Status Path

[QI W FirstAppindia/.classpath

@ |5 FirstAppindia/.gitignore

@ Wy FirstAppindia/.project

@ % FirstAppindia/AndroidManifest.xml

@ % FirstAppindia/bin/AndroidManifest.xml

@ |5 FirstAppindia/bin/FirstAppindia.apk

@ |5 FirstAppindia/bin/classes.dex

@ | FirstAppindia/bin/classes/.qgitignore

@ ;» FirstApplindia/bin/dexedLibs/android-support-v4-47bb79489%a18ab6e50b93188f780a23f.jar

(73 . S
@ Commit and Push Cancel [ Commit |

& MIT AT’
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